Mobile app compatibility

Petcube app requires iOS 8.4 or greater and Android 4.3 or greater.

Was this helpful? YesNo
Was this helpful? YesNo